Android build not working


#1

I am trying to put android on top of existing android which came with the board.
I downloaded linux_android_board_support_package_vla.br_.1.2.4-01810-8×16.0-3.zip and compiled it(by running DB410c_build.sh). The build failed saying "No rule to make target out/target/common/obj/JAVA_LIBRARIES/WfdCommon_intermediates/classes.jar’, needed byout/target/common/obj/PACKAGING/boot-jars-package-check_intermediates/stamp’ ", so I added following patch for msm8916_64.mk.

-PRODUCT_BOOT_JARS += qcmediaplayer \

  •                 WfdCommon \
    
  •                 qcom.fmradio \
    
  •                 oem-services
    

+PRODUCT_BOOT_JARS += qcmediaplayer
PRODUCT_BOOT_JARS += vcard
PRODUCT_BOOT_JARS += tcmiface
+ifneq ($(strip $(QCPATH)),)
+PRODUCT_BOOT_JARS += WfdCommon
+PRODUCT_BOOT_JARS += qcom.fmradio
+PRODUCT_BOOT_JARS += security-bridge
+PRODUCT_BOOT_JARS += qsb-port
+PRODUCT_BOOT_JARS += oem-services
+endif

When I try to boot from the built images, the board does not boot. I installed boot, recovery and system images from my build. Should I install any other images along with these?

P.S: When I installed 15.06 version from https://builds.96boards.org/releases/dragonboard410c/qualcomm/android/15.06/ through SD card, the board came up.


#2

Update: I downloaded “android_board_support_package_vla.br_.1.2.4-01810-8x16.0-2.zip” and built it without facing any issues. But when I try to load boot.img from it the board crashes. The following is the dump from serial console:

[580] fastboot: processing commands
[22580] fastboot: download:00fcc528
[23100] fastboot: boot
[23100] DTB Total entry: 212, DTB version: 3
[23100] Using DTB entry 0x000000f7/00000000/0x00000018/0 for device

0x000000f7/00010000/0x00010018/0
[23180] target_display_panel_node:510: hw_id=24 panel_name=""
[23180] cmdline: console=ttyHSL0,115200,n8 androidboot.console=ttyHSL0

androidboot.hardware=qcom msm_rtb.filter=0x237 ehci-hcd.park=3

androidboot.bootdevice=7824900.sdhci lpm_levels.sleep_disabled=1 earlyprintk

androidboot.selinux=permissive androidboot.emmc=true[23200] Updating device tree:

start
[23380] Updating device tree: done
[23390] booting linux @ 0x80008000, ramdisk @ 0x82000000 (795778), tags/device tree

@ 0x81e00000
[23400] undefined abort, halting
[23400] r0 0x00000000 r1 0x00000000 r2 0x81e00000 r3 0x644d5241
[23400] r4 0x8f685860 r5 0x000c2482 r6 0x82000000 r7 0x8f689264
[23400] r8 0x81e00000 r9 0x81e00000 r10 0x80008000 r11 0x80008000
[23400] r12 0x600001d3 usp 0x00000000 ulr 0x00000000 pc 0x80008000
[23400] spsr 0x800001d3


#3

Hi Kirin

Are you working from https://developer.qualcomm.com/download/db410c/linux-android-software-build-and-installation-guide.pdf or some other guide?

I’ve not tried installing yet but the build for linux_android_board_support_package_vla.br_.1.2.4-01810-8×16.0-3.zip worked cleanly for me when I followed that guide (although I used the ubuntu 14.04 machine I use for AOSP builds rather than 12.04).


#4

Hi Daniel,

Thanks for the reply.
I am also using Ubuntu 14.04. Also I did follow the same document you have mentioned for building. As given in the document, I directly ran the “DB410c_build.sh script”, which downloaded the code and built it.


#5

Update: I downloaded the bootloader from the path http://builds.96boards.org/releases/dragonboard410c/linaro/rescue/latest/dragonboard410c_bootloader_emmc_android-*.zip and flashed it. After this I flashed system, cache, aboot, persist, recovery and userdata from release image and on top of it flashed my boot.img and the board booted. I am not sure why it does not come up when I flash my Boot image without re-flashing bootloader.


#6

Thanks for the update, and glad to hear you have it working.