Amazon Alexa Voice Control Service Setup on the DragonBoard 410c


#21

I’m afraid I won’t be near a board til after the weekend. However I suspect
your apt.conf needs updating. It looks like it is pointed at an out of date
mirror. Try looking at the Debian documentation on apt and how to point it
at ‘oldstable’ (aka Jessie).


#22

can you please provide me the link where i will see the documentation and are you sure they are not supporting npm in the latest version .as they supposed to be as it is the newer version.


#23

Hello

Yes, I am sure the latest release doesn’t support npm:

Regarding reconfiguring apt I don’t think this is required. I am able to apt-get update just fine (on 16.06)… I think your connection to the internet might have not been working when you ran this command.

Daniel.


#24

hello sir

when i run npm it is throwing a warning ?


#25

when i start npm this problem occurs


#26

This warning may be harmless. I notice that there are WARN messages when the document author runs: npm start .


#27

hello sir
now i am getting error on when i try to run the client app in A2.9.2 i.e mvn exex:exec but it is showing errors not able to understand. please help .Amazon Alexa Voice Control Service Setup for Dragonboard 410c.


#28

hello sir

i am stuckin last part i.e 2.9.2 i am not getting solution for that can you please tell me how to solve this sir.Iam attach

screenshot here:
[ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (default-cli) on project sample-java-client: Command execution failed. Process exited with an error: 134 (Exit value: 134) -> [Help 1]

org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (default-cli) on project sample-java-client: Command execution failed.
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: org.apache.maven.plugin.MojoExecutionException: Command execution failed.
at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:362)
at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
… 20 more
Caused by: org.apache.commons.exec.ExecuteException: Process exited with an error: 134 (Exit value: 134)
at org.apache.commons.exec.DefaultExecutor.executeInternal(DefaultExecutor.java:377)
at org.apache.commons.exec.DefaultExecutor.execute(DefaultExecutor.java:160)
at org.codehaus.mojo.exec.ExecMojo.executeCommandLine(ExecMojo.java:610)
at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:352)
… 22 more
[ERROR]
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
linaro@linaro-alip:~/Projects/alexa/alexa-avs-raspberry-pi/samples/javaclient$ sudo apt-get update


#29

I looks like the latest version of the Amazon repository has introduced changes that cause the java client application to crash on DB410C.

To roll back to an older version of amzn/alexa-avs-raspberry-pi (preserving your config changes) try the following commands:

git config --global user.email <your_email>
git config --global user.name <your_name>
git stash
git checkout 2787fd6332d4f02785ed3bea4ccd9327b0d6652f
git stash pop

#30

what i had to write in place of global user, and in place of mail do i had to write the mail which i made in amazon developer account. please reply as soon as possible.


#31

Anything that the tool accepts is OK (it will only be used to tag the changes when you call the stash command - the value will never leave you computer).


#32

mine is not working will you please explain in details .


#33

As before always explain what is not working for you (it is currently being discussed elsewhere on the forum that http://raspi.tv/2017/how-to-ask-for-and-receive-technical-help-on-the-internet describes some very good habits to adopt in order to make yourself easier to help).

Anyhow, if you cannot successfully follow the short cut instructions I shared yesterday then you will need to delete or rename the alexa-avs-raspberry-pi directory and start again from step 2.1. Just perform two extra lines after step 2.1:

cd alexa-avs-raspberry-pi
git checkout 2787fd6332d4f02785ed3bea4ccd9327b0d6652f

The effect of the git checkout command will remove many changes from the source code… including the change that causes the code to crash when bringing up the GUI.


#34

thank you sir
now mvn exec:exec command is is working …
now in the 2.10 step i am not able to obtain authorization from Login with Amazon…
and when i paste the url on a web browser i got an error occurred and" we are tried to process your request" how to resolve this sir . please reply as soon as possible .
below are the screenshot :


#35

these are the details


#36

Take another look at step 2.3.7 (where you set the allowed return URLs). I think you have not setup these steps correctly.


#37

@danielt
no sir they are correct and have done just according to the setup guide, i just checked ? what to do now and what might be the reason ?please tell


#38

Sorry. I didn’t read the error summary correctly. Actually is says you have a bad client_id (and also shows you the client_id). Does this match the client ID you got when you set up alexa?


#39

@danielt
sir now in step 2.10.6 only “listening” button in place of "start listening button " but thats also ok when i speaks processing is shown but its not working and no “stop listening” button appears even. please help sir as soon as possible .


#40

I’m afraid I can’t really help much more on this topic. I don’t have a microphone attached to my DB410C so I don’t really know what the system is supposed to do when it stops listening.

According to the documentation from Amazon the instructions for the listen button are: “If you prefer, you can also click on the “Listen” button, instead of using the wake word. Click the “Listen” button and wait for the audio cue before beginning to speak. It may take a second or two before you hear the audio cue.”