Amazon Alexa Voice Control Service Setup on the DragonBoard 410c

hello sir

i am stuckin last part i.e 2.9.2 i am not getting solution for that can you please tell me how to solve this sir.Iam attach

screenshot here:
[ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (default-cli) on project sample-java-client: Command execution failed. Process exited with an error: 134 (Exit value: 134) -> [Help 1]

org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (default-cli) on project sample-java-client: Command execution failed.
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: org.apache.maven.plugin.MojoExecutionException: Command execution failed.
at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:362)
at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
… 20 more
Caused by: org.apache.commons.exec.ExecuteException: Process exited with an error: 134 (Exit value: 134)
at org.apache.commons.exec.DefaultExecutor.executeInternal(DefaultExecutor.java:377)
at org.apache.commons.exec.DefaultExecutor.execute(DefaultExecutor.java:160)
at org.codehaus.mojo.exec.ExecMojo.executeCommandLine(ExecMojo.java:610)
at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:352)
… 22 more
[ERROR]
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
linaro@linaro-alip:~/Projects/alexa/alexa-avs-raspberry-pi/samples/javaclient$ sudo apt-get update

I looks like the latest version of the Amazon repository has introduced changes that cause the java client application to crash on DB410C.

To roll back to an older version of amzn/alexa-avs-raspberry-pi (preserving your config changes) try the following commands:

git config --global user.email <your_email>
git config --global user.name <your_name>
git stash
git checkout 2787fd6332d4f02785ed3bea4ccd9327b0d6652f
git stash pop

what i had to write in place of global user, and in place of mail do i had to write the mail which i made in amazon developer account. please reply as soon as possible.

Anything that the tool accepts is OK (it will only be used to tag the changes when you call the stash command - the value will never leave you computer).

mine is not working will you please explain in details .

As before always explain what is not working for you (it is currently being discussed elsewhere on the forum that http://raspi.tv/2017/how-to-ask-for-and-receive-technical-help-on-the-internet describes some very good habits to adopt in order to make yourself easier to help).

Anyhow, if you cannot successfully follow the short cut instructions I shared yesterday then you will need to delete or rename the alexa-avs-raspberry-pi directory and start again from step 2.1. Just perform two extra lines after step 2.1:

cd alexa-avs-raspberry-pi
git checkout 2787fd6332d4f02785ed3bea4ccd9327b0d6652f

The effect of the git checkout command will remove many changes from the source code… including the change that causes the code to crash when bringing up the GUI.

thank you sir
now mvn exec:exec command is is working …
now in the 2.10 step i am not able to obtain authorization from Login with Amazon…
and when i paste the url on a web browser i got an error occurred and" we are tried to process your request" how to resolve this sir . please reply as soon as possible .
below are the screenshot :

these are the details

Take another look at step 2.3.7 (where you set the allowed return URLs). I think you have not setup these steps correctly.

@danielt
no sir they are correct and have done just according to the setup guide, i just checked ? what to do now and what might be the reason ?please tell

Sorry. I didn’t read the error summary correctly. Actually is says you have a bad client_id (and also shows you the client_id). Does this match the client ID you got when you set up alexa?

@danielt
sir now in step 2.10.6 only “listening” button in place of "start listening button " but thats also ok when i speaks processing is shown but its not working and no “stop listening” button appears even. please help sir as soon as possible .

I’m afraid I can’t really help much more on this topic. I don’t have a microphone attached to my DB410C so I don’t really know what the system is supposed to do when it stops listening.

According to the documentation from Amazon the instructions for the listen button are: “If you prefer, you can also click on the “Listen” button, instead of using the wake word. Click the “Listen” button and wait for the audio cue before beginning to speak. It may take a second or two before you hear the audio cue.”

@danielt and @jmjobin
as you have done work on audio mezzanine could you please tell me how to run its audio part as i am stuck in that step 2.10.6 (How to Setup Amazon Alexa Voice Control Service on the DragonBoard 410c).please tell me as soon as possible

hello sir please tell me the solution if you can please sir as i am not getting any good solution for this project is almost about to complete if this works :cry::sob: and please tell me the solution .

thanks

@ren_snappy
Sorry I used it only with Android and never connect to Alexa yet. Let Daniel to help you :slight_smile:

@danielt
sir it is still not working please help.

Hello @danielt
as you said you dont have a microphone attatched to DB410C ,so can you please tell me earphone (they also have microphone in that) .will work or we have to buy microphone.

@jmjobin
can you please tell me how it works for android using audio mezzanine for you please.as i am using headphones and no sound i heard

Hello ren_snappy,
It is easy you just search for any radio internet app and listen to it.
Raise the level by pushing on the dragonboard level button and then regulate it with the mouse.

But just wonder, did you add (solder) the connector “ANALOG EXP” on the Dragonboard?

Hello @jmjobin
i used audio mezznine board along with header and when i used that for android based dragonboard it immediately heated up don’t know why ?
Thanks