Amazon Alexa Voice Control Service Setup on the DragonBoard 410c


#1

I am trying this on my dragonboard 410c .i install linaro’s supported debian (linux) operating system on dragonboard 410c did the steps till 2.3 but got stuck how to solve this problem in step 2.4 i.e to generate SSL certificate.

[https://developer.qualcomm.com/sites/default/files/attachments/alexa-service-db410c.pdf]

got stuck in the step 2.4 . after typing in LXTerminal i got bash command that does anyone know how to generate self signed certificates on linux as i was following the commands mentioned but facing problem in this . does anyone facing same problem please help.

Thanks


#2

Please can you share a screenshot showing what happens when you run these commands?


#3

#4

these are the screenshots:


#5

this is the output i am getting on LXTerminal when i typed above command as written in the step 2.4


#6

@danielt @sdrobertw
hello sir it still not working same problem i am getting same output as attatched in the screenshot after
1.1 Install VLC media player
1.2 Install Node.JS
1.3 Install Java development kit
1.4 Install Maven
1.5 Install oppenSSL
2.1 Download the sample app code and dependencies on the DragonBoard410c
2.2 Register for a free Amazon Developer Account
2.3 Register your product and create a security profile.
till this point
2.4 Generate self-signed certificates (in this step i am still having problem same problem how to solve this problem?) what to do :fearful::tired_face: ?


#7

Well I can tell you that you do not have a file or directory called …/samples/javaclient . However I hope you could have told me that, given it is already written on your screen! Between shrinking the terminal window and cropping your photo you have ended up removing all information from you photo that we might use to help you…


#8

This is the complete Photo

as it is clearly written no such file or directory but how to solve this as i told you i followed the steps told by Qualcomm Developer Network? i am seriously not getting what to do now as i am new to linux ?


#9

Yesterday I said:

I’m afraid the full photo of the shrunken terminal window is still insufficient.

Did you see any error messages when you ran the earlier commands?


#10

hello sir
now i am having a problem in step2.8

1.1 Install VLC media player
1.2 Install Node.JS
1.3 Install Java development kit
1.4 Install Maven
1.5 Install oppenSSL
2.1 Download the sample app code and dependencies on the DragonBoard410c
2.2 Register for a free Amazon Developer Account
2.3 Register your product and create a security profile.
till this point
2.4 Generate self-signed certificates
2.5 Install the Companion Service dependencies
Change directories .
2.6 Create Security Profile .
2.7 Updating the config files
2.8 Run the server in this step ( i am having problem problem how to solve this problem?) what to do :fearful::tired_face: ?search a lot but did not worked.

here when i typed "npm start"i got problem in this step and bash : npm command not found is error " in debian ?
please help

Thanks


#11

I’ll take a look at this in the next day or two.

In the mean time, can you let me know how you solved your previous issue?


#12

Hello sir
actually i am a new on linux so that was the big reason for that but in my case i hade done this “/home/linaro/Projects/alexa/alexa-avs-raspberry-pi/”: to “Projects/alexa/alexa-avs-raspberry-pi/” in place of refference implementation in 2.4. and then it works otherwise earlier it says no such file or directory.

sir can you please resolve my above problem of 2.8 today if you can please as i had to do this for my project .:cry::sob:

when i try to install node.js again then also it is showing me the same problem as in when i tried it for npm installation.

“i got error as E: Unable to correct problems,you have held broken packages”

Thanks sir


#13

#14

Are you using the 17.04 (or 17.04.01) debian release? If so I think this is your problem.

Debian removed npm support in Debian Stretch so the instructions from Qualcomm will only work if you use one of the older Debian images (acording to https://developer.qualcomm.com/project/audio-mezzanine-board the Alexa instructions were tested using 16.06).


#15

Hello sir

Right now i have downloaded the same version (4.9.30-lt-qcom) which was told by Qualcomm
but still it is not working even following as per instructions .:cry::sob:
https://developer.qualcomm.com/project/audio-mezzanine-board and thanks for telling me that npm is not supported in Debian Stretch. i willtry to download again but will you please give me any link for older version from where i can download debian again other than (https://developer.qualcomm.com/project/audio-mezzanine-board) as i am already using this image.

Thanks


#16

Having a v4.9.30-lt-qcom kernel shows you are using one of the newer releases >= 17.04 (the newer releases don’t support npm). As I said before the instructions on the qualcomm site have only been tested with 16.06 (see http://builds.96boards.org/releases/dragonboard410c/linaro/debian/ ) although they will probably also work with 16.09 .


#17

Hello sir
i want to correct i was using the debian os which was provided by 96 Boards and now i rebooted from https://developer.qualcomm.com/project/audio-mezzanine-board and now even for updation i am getting errors.while typing "sudo apt-get update " i am getting errors why ?(now it is really too much i am not getting anything ) sir please help and if you can please provide me the link from where i can download debian image in which audio mexzzanine will work as i tried a lot .:cry::sob:

Thanks


#18

Might need a screenshot with that one…


#19

i have sent you that above.


#20

hello sir and @jmjobin @sdrobertw

if you can please tell me as i had to make the use of mezzanine board , but as told by you even i changed my linux operating system from stretch to older version but in those versions i got stucked in the very first steps . I think they have used some other linux distribution other than stretch as i had tried debian 16.4,16.6,16.9 and 17.04 but all are creating problem.i think i made a mistake (choosing audio mezzanine now i am really lost what to do ?) please help as i had to submit this project within 2 days. :cry::cry::sob::sob:

Thanks