ADB devices command not working


#1

HiKey Board (LeMaker)
Board based on HiSilicon Kirin 6220 processor

More Info: http://www.96boards.org/product/hikey/
Buy now: http://linaro.co/hikey-lenovator-buy

  1. I flashed Android 7
  2. I enabled developer mode and then USB debugging in the Android settings window
  3. Added following to my Ubuntu host machine (in the file /etc/udev/rules.d/51-android.rules)

fastboot protocol on HiKey

SUBSYSTEM==“usb”, ATTR{idVendor}==“18d1”, ATTR{idProduct}==“d00d”, MODE=“0660”, GROUP=“dialout”

adb protocol on HiKey

SUBSYSTEM==“usb”, ATTR{idVendor}==“12d1”, ATTR{idProduct}==“1057”, MODE=“0660”, GROUP=“dialout”

rndis for HiKey

SUBSYSTEM==“usb”, ATTR{idVendor}==“12d1”, ATTR{idProduct}==“1050”, MODE=“0660”, GROUP=“dialout”

  1. Connected the USB micro cable to host machine.

Still cannot find hikey device using the command $ sudo adb devices

How can I get a shell access to the hikey device? Am I missing something? Following is what I am getting! I spent quite some time now on this. Not sure what is wrong. I did restarted adb many times and tried it on different machine too. Any help?

[17:11:20] karthik@sec:~/Desktop $ dmesg
[ 851.528325] usb 1-13: device not accepting address 21, error -62
[ 851.640374] usb 1-13: new high-speed USB device number 22 using xhci_hcd
[ 856.652643] xhci_hcd 0000:00:14.0: Command completion event does not match command
[ 856.652651] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[ 861.868550] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[ 862.072574] usb 1-13: device not accepting address 22, error -62
[ 862.072627] usb usb1-port13: unable to enumerate USB device
[17:11:23] karthik@sec:~/Desktop $ sudo adb kill-server
[17:11:31] karthik@sec:~/Desktop $ sudo adb devices

  • daemon not running. starting it now on port 5037 *
  • daemon started successfully *
    List of devices attached

[17:11:36] karthik@sec:~/Desktop $

I also see Select USB Connfiguration in the android settings window. I tried MTP and PTP in that. Still no luck finding device with ADB command. :frowning:


#2

As answered in https://github.com/OP-TEE/optee_os/issues/1439.