Adb daemon on 410c Linux


#1

Hi,
Has anyone tried to get adb daemon running on 410c Linux/Ubuntu? i.e When I plug a 410c running Ubuntu to my HOST PC, I want it to show up as an adb device.

Thanks


#2

Hi Ashwin
I have not tried this on DB410c. But this was possible on the Ifc6410.
Steps are documented here:
https://wiki.linaro.org/Boards/IFC6410/LinaroUbuntu#How_to_install_setup_and_use_Android_ADB

Once it works, we should preload the android-tools-adbd and a preconfigured : android-tools-adbd.conf as part of the ALIP or the Developer image .

I will try it later today or tomorrow and update this thread.

-Sujai.


#3

Hi Sujai, Did you have any luck with this?

Thanks
Ashwin


#4

Hi Ashwin
I couldnt get the arm64 version of android-tools-adbd (although android-tools-adb) is available and I could install it.
I couldnt get to cross compile android-tools-adbd for arm64 yet. If anyone can share me the procedure to setup a cross compile environment for AARCH64 it would be good.

-Sujai.


#5

we are currently looking into that… hopefully we should get it soon…


#6

Hi,

I tried putting ADB from following link to yocto build. It got built and adbd starts running after boot. But I cannot see it when I run “adb devices” from the host machine.
I got adb from the following link:
https://github.com/shr-distribution/meta-smartphone/blob/danny/meta-android/recipes-android/adb/adb_git.bb


#7

unfortunately, this is still work in progress… we have this bug to track:

https://bugs.linaro.org/show_bug.cgi?id=2179

you are pointing to a very old branch (danny).

there is also working going on in this area upstream:

https://patchwork.openembedded.org/patch/125961/

if you could have a look at this and help, that would be appreciated.


#8

Thanks for the update. I will try to build with this patch and see what happens.


#9

I Was able to get adb shell up on yocto. I followed the instructions from this blog:


#10

hi, thanks for reporting it! can you share a bit more info about how you got it to work? for example, which version/branch of the manifest you are using, which tools did you add to the image, …

thanks!


#11

I am using jethro branch. I downloaded and added “android-tools” recipe from the following link:
https://github.com/shr-distribution/meta-smartphone/tree/master/meta-android/recipes-android/android-tools/

I added this in the path: layers/openembedded-core/meta/recipes-connectivity and built it.
Along with this I “Function Filesystem” in kernel.


#12

I got it working under Debian.
adbd - compiled from openembedded/jethro brach. The libcrypto dependency was conflicting with ssh on Debian, so created standalone adbd executable.
kernel - functionFS enabled