820c won't boot nor recognize fastboot anymore


#1

Hey people,

I was working on my DB820c a few days a go and flashed an Android image into the dragonboard.
Since that the board do not recognize fastboot and I couldn’t make it boot again.
Power led lights up and stay light, also BT and Wifi leds lighten and after a few seconds go off.

I’ve tried every recovery tutorial available in the Recovery Board Section but no sucess, fastboot method, sd card recovery and so on,

I’ve also tried to use QDL to download the tables again on th board but the QDL doesn’t recognize the serial communication.(I’m using a this Mezzanine Board to do that)

Is there any other way to bring the board back to life? Any tips?

Thanks in advance!


#2

QDL hooks into the device at more or less the lowest level available (it will be running from an internal ROM). If you cannot make the board enumerate via USB then it is almost certainly broken.

As a final I’d recommend unplugging everything (power, SD card, USB, HDMI, even the mezzanine). Then set the switches for recovery mode and connect only power and micro USB. Finally check so see if any USB device is enumerating at the other end of the USB cable (can be seen in sudo dmesg | tail on most GNU/Linux systems).


#3

QDL does not use the debug Serial/UART but the onboard micro USB.