5.4.25 kernel is cross compiled and modules installed but no wireless extensions [SOLVED]

As i read over the web, my model c is featuring a AP6255 WiFi/BT combo which is also a BROADCOM43455 clone.

I cross compiled longterm 5.4.25 kernel on my model c and installed modules. My SBC is booting fine BUT WiFi device is not properly picked up : brcmfmac, brcmutil and cfg80211 modules are loaded though…

In the stock dtsi file, there is this section (for ab i presume…) :

	brcmf: wifi@1 {
		compatible = "brcm,bcm4329-fmac";
		reg = <1>;
		interrupt-parent = <&gpio0>;
		interrupts = <RK_PA3 GPIO_ACTIVE_HIGH>;
		interrupt-names = "host-wake";
		pinctrl-names = "default";
		pinctrl-0 = <&wifi_host_wake_l>;
	};

… i tried to replace bcm4329 by bcm43455 in the code above but the WiFi device is still not properly loaded : no wireless extensions given by iwconfig.

Thanks for any help !

Its not a clone. Its got an ACTUAL broadcom chip.

AP6255 is the MODULE, which includes a PCB, a metal shield, a few secondary components like capacitors, and a broadcom chip.

Thanks for clarifying things.

BT and WiFi FW were missing : i grabbed them from ‘https://github.com/rockchip-linux/rkwifibt/tree/master/firmware/broadcom/AP6255’.

BT and WiFi are now working, nevertheless brcmfmac is complaining about missing CLM blobs :

[ 12.665740] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 12.666202] usbcore: registered new interface driver brcmfmac
[ 12.839325] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 12.839406] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 12.839803] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Jan 26 2018 14:54:15 version 7.45.96.17 (d216b2a@shgit) ® FWID 01-a521145 es7.c5.n4.a3

I successfully compiled 4.4 kernel. But it would be interesting to know how you managed to build a 5.4 kernel that works. I do not even get serial console output working for 5.4 kernel.

Everything works fine now with version 5 kernel but for all that have the same issues you have to use console=ttyS2,1500000n8 in /boot/extlinux/extlinux.conf to see console output on serial console or you will see nothing.