410c Windows 10 IoT - Screen Resolution

Minnowboard Max/Turbot devices have hardware accelerated graphics as well. Their TPM is only half there, though. The DragonBoard supports Azure key storage AND bitlocker, while the Max/Turbot only support enough TPM features to enable bitlocker.

It is hard to find one board that “has it all”. If the DragonBoard had a realtime clock, it would be very close to ideal.

I also ran the DragonBoard on 1080p! But can someone adapt this code for the 1024x600 touch screen?
I’ll appreciate that.
Thanks in advance.

After adding the panelcfg.xml to the sd card, the 1080p resolution works, but is there a way to change the dpi scaling for uwp apps?

@andy66 @miroslav.chakarov

In Insider Preview 10.0.17733.1000 they fixed the problem with Full HD on Dragonboard 410c.

They also fixed the issue with scaling ratio (150%) so finally 1920x1080 is not longer scaled from 1280x720 (150%)


Thank you for reporting this. I can’t find any changelog for this insider build, do you have a link?

Edit: Found the changelog, but there is no description about this fix.

Best Regards

Andy, I suspect that all the resolution problems you have are related to the particular display you are trying to use. It’s HDMI interface may be poorly implemented and Windows may not be able to detect correctly it’s native resolution. In my case I had no issues using a 10" 1024x600 and a 24" 1280x1024 display interchangeably with DB410C, on startup the code detects the display plugged in automatically. But I need to make clear that I’m using a quality 10" display from Xenarc Technologies. This isa ruggedized display that goes for about $600 USD. If you are using a $90 display from Amazon (on which I also wasted my money before) you get what you are paying for.


Previously i used an RPi3 with my screen without any issue. With the panelcfg file on the SD card it works good. I have to test one of the new insider builds of IoT Core, according to @mmichalak suggestion. This seems to solve the problem on the Dragonboard.


Finally had time to test and installed the latest Insider preview (10.0.17744.1001), but there is no FHD (1080p) available to me. Tried with different screens. Only 720p is selectable on the device portal.

Edit// I tested also with the latest official Debian Image for the Dragonboard 410c, 1080p is working there, it recognizes the monitor model too. So it has to be an issue with Windows IoT Core.

See if you find something in the Windows IoT forum:
Msdn forums - Windows IoT
I had an issue with serial ports not working that turned out to be the a problem with the ACPI drivers that Qualcomm needs to fix. That seems to affect also I2C and other I/O functionality.

Thank you @GUILLERMO. Was your issue on an older build of Windows IoT? And was it solved? When i take a look at the last few changelogs, it seems that the used BSP from Qualcomm never changed. So i don’t know, if such “issues” really get fixed anytime soon.

Hi Andy, I’m still working on the UART issue. Just loaded today a fresh re-flash of the latest stable Windows IoT Core 10.0.17134.1, I downloaded the latest BSP package available from Qualcomm but there are no .FFU images there. Hopefully I don’t have to go through the pain to recompile them. I’m awaiting some answers from Qualcomm regarding that before I waste more time on it. You can follow this thread here: https://discuss.96boards.org/t/uart-devices-of-dragonboard-410c-are-broken-in-latest-release-of-windows-iot-2018/5913/8

Hi Guillermo. Ok that’s odd. Did you test with the latest insider preview already? Regarding recompiling, i have already created some own images (FFU), but we can only use the available BSP file from Qualcomm, i don’t know how to modify this, when creating an image.
Is the current available BSP really new? As i wrote above, i haven’t seen any version changes on thr BSP since months.

Hi Andy, The BSP files are relatively recent, less than 30 days old 8/29/2018 or newer as the file dates you can see inside the ZIP, here is the first part of the readme (they don’t bother to put the release date of each one):

DB410c BSP release notes

The current release is 2120. Following table gives a brief description of fixes made
in the current and some of older releases.

Release# Content
======== =======
2120 UEFI packaged as part of QDN release
HDMI audio support

2119 WLAN firmware update for Krack fix
HDMI autodetect feature

2118 SMBIOS type 2 table support
WLAN host driver fix for Krack (partial)

2117 WLAN Tx power limit fix
QCBinGenTool – source packaging fix
NV2 binary packaged as part of DPP
RS2 update (15063.540)

2116 QCBinGenTool – to help OEMs with the factory flow
MSFT-Signed HAL drivers included
Fix for UM graphics crash
WiFi scanning fix (CR 2029503)

2115 Secure boot fix (TZ image)

2114 Fix for connected standby issue
CPU floor (< 200 MHz possibility)

Hi Guillermo, i downloaded the current BSP from Qualcomm today and saw the changes too, thank you for providing the changelog.
The weird Thing is, why MS is using the older 2118 build of the BSP. I think that 2119 was available when they build the 17744 build of the current Insider preview of Windows IoT Core. The latest Insider preview seems to be 17763, but this was only posted on MSDN Forums, but without a hint to the used BSP Version (LINK)
But i’m not able to receive this build via Windows Update on my Dragonboard. So if it is not still not available until the weekend, i will give it a try and build my own FFU with the latest 2120 BSP.

Now i had time nad built an FFU image based on the latest Windows IoT Core release (non Insider), which is build 17134. I created this FFU with the latest Qualcomm BSP (2120) and finally, 1080p works without any issues. To test and compare, i took the same 17134 build which is available as pre-built Version from Microsoft (this one uses the BSP version 2118). I compared the OS Version after flashing, both were exact the same, only the BSP was different. With the one with the older BSP, 1080p was not possible, with the FFU with newer BSP, 1080p was recognized on first boot, without any problems. So then we have to wait for MS that they use the new BSP within their pre-built Images.

The only issue Right now is, that MS seems not to provide Audio over HDMI. With the latest BSP, this was also added. But within Windows IoT Core, we don’t have the Option to switch to this Output, even over PowerShell, the device was not found.

Finally, with the october update (build 10.0.17763.1) 1080p works for me. But sadly, MS did not use the current BSP from Qualcomm, but that’s another Story.

Edit// As it turns out, MS is using the latest BSP in their october update :slight_smile:

Hi Andy, I was away for a while and just reading this. Glad to know that you solved the video problem. I’m surprised to learn that you managed to build the FFU out of the BSP. Did you do it the (broken) QUALCOMM way, or the Microsoft way (https://docs.microsoft.com/en-us/windows-hardware/manufacture/iot/create-a-new-bsp)? it seems that you did the later.

I spent hours trying to compile it but the Qualcomm instructions are incomplete and most likely outdated. I’m going to try the Microsoft way next. But it seems for what you say that Microsoft built the latest BSP already in the October update. Unfortunately the UARTs are still broken, you can see them listed under the ACPI tree in the live OS, but can’t be open with the SerialDevice() API.

Hi Guillermo, I did it the way which Microsoft has documented. But for me this is not required anymore, because of the october update which has the newest BSP included already. Regarding UART, i recommend that you post this issue (again if you have already) on the Microsoft IoT GitHub page and on MSDN Forums.

Best Regards

sorry for the convenience , May I know what are all the exact issues you are facing , when compiling windows BSP from QC , Please use Windows 10 IoT BSP for DragonBoard 410c Customization Guide available at https://developer.qualcomm.com/hardware/dragonboard-410c/software

did you manage to set up waveshare 1024 600 screen?if Yes? can you help me?
I read the pdf document for creating my display configuration, and I think there is something missing. The EDID contains more information than you need to write to panelcfg.xml file. You can’t enter Pixel clock, screen refresh rate, and other parameters that are created based on them

0x00 0xFF 0xFF 0xFF 0xFF 0xFF 0xFF 0x00 0x04 0x81 0x04 0x00 0x01 0x00 0x00 0x00 0x01 0x11 0x01 0x03 0x80 0x0F 0x0A 0x00 0x0A 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x01 0x80 0x0C 0x00 0x80 0x40 0x58 0x2D 0x20 0x28 0x30 0xD3 0x00 0x6C 0x44 0x00 0x00 0x00 0x18 0x00 0x00 0x00 0x10 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x10 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x10 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x9F

Частота обновления экрана 43Гц