4.19.5 kernel based Debian snapshot image release for HiKey960

@sreenad The repository you pointed out is the correct one but I haven’t tested 4.9 branch. hikey960_upstream_rebase branch is known to be working.

Thanks @Mani for your quick reply.

Kernel version in hikey960_upstream_rebase is shown as 4.14.
Is there a repo or branch with kernel 4.9 (non android) available for hikey960 which is still maintained.?

Regards,
Sreenad.

@sreenad, thanks now it works!

You may use:
$ sed -i 's/=m/=y/g' .config

@sreenad AFAIK, there is no 4.9 branch which is still maintained. But you can try using the one you pointed out and share the results with us :wink:

@marcodip, Thanks, I did similar thing in Vim editor. :%s/=m/=y/g

But usually editing .config directly is not encouraged.
So just wanted to know whether any make target is available for it.
Some thing like make inbuilt_modules_config which can give a proper .config.

@Mani, kernel 5.2 works fine without devicetree.

If I add devicetree /boot/hi3660-hikey960.dtb, it cannot start.

I installed the kernel with dpkg.

That’s wierd. But it usually means, the dtb is not good.

Hi @sreenad,

is there any specific reason to build all the features into the kernel, not as module?

Is it possible to use modules too? As I would like to unload/load a specific module at run-time.

Thanks,
Marco

Hi @marcodip,

You can use modules. I prefer ‘inbuilt’ to avoid

  • missing drivers.
  • Vermagic mismatches
  • Additional task of installing modules.

Regards,
Sreenad.

Hi @sreenad,

got it, thanks! Just another question: why you call this?

make olddefconfig

Regards,
Marco

Hello @Mani,

Is there any Debian/Ubuntu release in which HDMI & WiFi works ?
Thanks in advance !

@Rajagopal No HDMI for now but WiFi should work with latest release.

http://snapshots.linaro.org/96boards/hikey/linaro/debian/latest/

Hello Mani,

Appreciate the timely reply.

No HDMI for now but WiFi should work with latest release.
Wondering why in Android we can get HDMI o/p but NOT in Linux.
Or, is it right in Android also HDMI doesn’t work & only MIPI-DSI works ?

Thanks.

@Rajagopal The debian image is based on the latest LTS kernel and it doesn’t contain many out of tree drivers (of course there are usb patches but they are taken from mailing list). If you want to use HDMI but doesn’t worry about kernel version, then you can try below kernel:

This kernel has almost most of the features supported by Hikey960. And you can update this kernel on the board using below guide:

You can also refer previous conversations in this thread for more info.

Thanks,
Mani

@Mani Thank you for the links. When I tried to boot from the newly built upstream-rebase kernel, it complains saying “could not open builtin file /lib/modules/4.14.0-rc7-hikey-linaro-00001-ge2e79b4/modules.builtin.bin”.

I enable loadable module support in kernel config and built bindeb-pkg, modules & modules_install with custom INSTALL_MOD_PATH.

Still, I don’t see any .ko inside the entire linux directory !!!

How/where to get .ko for above kernel or how to get around the above error ?

Thanks,
Rajagopal

Hello @Mani,

For the above issue, tried the solution by @sumit.garg in [1] and was able to boot successfully but, no HDMI ouput yet !

Our monitor is a full-HD 32" Samsung monitor and tried passing video=HDMI-A-1:1920x1080@60 by appending to the “linux …” line in grub entry.

Does upstream-rebase support HDMI or de we have to run any additional commands/script to get HDMI output ?

Thanks,
Rajagopal

[1] Does latest rpb desktop image (Debian) supports hdmi on hikey960?

Did you update device-tree as well via grub menu as stated here?

How can I extract rootfs-linaro-stretch-developer-hikey-20191020-39.img

How can I make rootfs-linaro-stretch-developer-hikey-20191020-39.img

@lihuadong You can use simg2img utility to extract the raw rootfs image as below:

$ simg2img rootfs-linaro-stretch-developer-hikey-20191020-39.img rootfs.raw

Then the raw image(ext4 file system) can be mounted as below:

$ mkdir mnt
$ sudo mount rootfs.raw mnt/
1 Like