4.19.5 kernel based Debian snapshot image release for HiKey960

make defconfig distro.config based on this guide: https://github.com/96boards/documentation/blob/master/consumer/hikey/hikey620/build/linux-kernel.md

Thanks @Mani. Having a go at it now. There seems to be a problem downloading the linaro toolchain in latest (403 Forbidden). Going by specific release works though, e.g. - http://releases.linaro.org/components/toolchain/gcc-linaro/7.3-2018.05/

Can i pull this new kernel as the debian package from a repository @https://obs.linaro.org ?

Hi @helg,

Yes, you can do that using below steps:

  1. Add below entry in /etc/apt/sources.list
    deb http://obs.linaro.org/linaro-overlay-stretch/Debian_9.0/ ./

  2. Install the kernel:
    i) apt update
    ii) apt install linux-image-4.19.5-hikey

  3. Modify device tree at grub when booting the new image

PS: Thanks to @suihkulokki for the repo link.


is the HDMI supported in this release?

@Moshe_Eliyahu Sorry, not yet. But it will be supported in next release.

Hi, by any chance, does this release support Xen? I have posted on another thread regarding my failure to booting Xen with this release. Whereas, I have had success booting Xen using an earlier image extracted from linaro-stretch-developer-20180416-89.tar.gz. As my boot log has shown, this release does not provide a workaround for Xen’s scheduler to handle big.LITTLE. I have tried passing hmp-unsafe=true and dom0_vcpus_pin=true to the Xen command line to no avail. I appreciate if you or someone in the community could shed some lights on this. Thanks,

@Mani, can you please let me know where to get the source for the kernel, as i am trying to built the perf tool for it. Thanks


I tried compiling your kernel today and ran into a small build issue. The one-liner in this link fixes it:


Just build and installed the kernel debian package 5.0 and 5.1.0-rc6 on the image: http://snapshots.linaro.org/96boards/hikey/linaro/debian/30/
on both SD card and UFS and I see the same issue

the boot process for 5.0 stops at:
for 5.1 kernel:
the same kernel are working fine in android enviroment with the same boards, any hint?


Try to enable early console via kernel cmd line (earlycon=pl011,0xfff32000,115200).

Hi @Mani, since I’m looking at the latest debian should be “30” from http://snapshots.linaro.org/96boards/hikey/linaro/debian/ is the kernel 4.19.5 in this release or in previous one? also sd card image has that kernel? Thanks

Yes, release 30 is based on 4.19.5 kernel but there is no SD card image.

sorry @mani but i see http://snapshots.linaro.org/96boards/hikey/linaro/debian/30/linaro-stretch-developer-hikey-20190420-30.sd.gz , am I in the right repo?

@francesco_camarda I should’ve clarified. We do have SD card image but it is not tested on Hikey960!

@mani …I tested it and was not working, the latest working kernel for debian sd for me is the 4.18.
So i will try the UFS debain image, Thanks! F.

@mani, the UFS image is fine, the SD card one is freezing @:

[    3.854640] Run /init as init process
Loading, please wait...
[    3.867323] mmc_host mmc1: Bus speed (slot 0) = 25000000Hz (slot req 25000000Hz, actual 25000000HZ div = 0)
starting version 232
[    3.878666] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    3.879818] random: udevadm: uninitialized urandom read (16 bytes read)
[    3.880183] mmc1: new SDIO card at address 0001
[    3.886518] random: systemd-udevd: uninitialized urandom read (16 bytes read)

where the kernel seems to init the mmc card another time.

Hi Mani, are you going to test the SD card image too? Is there any instruction or suggestion that you could provide to make the SD image boot?


@Mani I am also unable to boot 4.19.5 via SD card on hikey960. UEFI hangs in console when any SD card is present at boot.

1 Like